Site Updates: Red Wunz Go Fasta!

SpeedLast week I began doing a lot of work on the site, though most of it behind the scenes. Frequenters of the site may have noticed the blog list got moved to a page all its own instead of showing in the right sidebar (Update: I’ve revised this and moved the blogroll back as it was). There’s a reason for it but I won’t bore you all with the details of some of these seemingly small changes.

The big change I implemented, and finally got working correctly this weekend, was caching. Most of you are familiar with what caching is to some degree. Getting it running efficiently and effectively on this website proved to be a chore. There’s many nuances with setting up proper caching and it was trial by fire. It is all done though and you should see a rather significant speed increase on the site. The biggest reason I mention this though is for you to tell me if anything looks wrong or is not working. As noted, caching requires some finesse so I may have overlooked an item in setting things up.

I’m happy with the results I’m seeing. It was a pain in the ass to get right but it should be well worth my efforts.

  • Warren Falconer

    Every once in awhile when I jump back to a page it seems like the cache is failing to load the css styles for text. I get images but no titles or text on anything. A refresh seems to fix this though, just wanted to pass it on

    • I noticed that testing it yesterday but thought it may have just been me. You using Chrome?

      • Warren Falconer

        Yes sir chrome, should have included that in the comment.

        • From what I can find it’s a bug with Chrome and it’s not related to the caching; currently caching is off while I work on this. Trying to find the solution is proving to be a chore though.

          • I think I finally fixed it. It was in fact a bug in Chrome and rendering CSS.

    • I think I may have found the culprit. Let me know if you notice it again.

      Never mind, still an issue. Damn it.

%d bloggers like this: